Tabellenkalkulation
Von: рарраbаеr (abgemeldet), 20.6.2010 18:22 Uhr
hallo an alle
ich möchte in excel eine liste zusammenrechnen aber nur wenn in diesen feldern ein eintreg gemacht wurde. die listen sind unterschiedlich lang.
wie mache ich es, das nur felder berücksichtigt werden in denen ein eintrag gemacht wurde und die leeren nicht berücksichtigt werden.
habe es mit =wenn(a1>0;a1;wenn(a2>0;a1+a2;wenn(a3>0;a1:a3;"") versucht, bekomme aber als ergebniss immer
#wert!bitte helft mir



  1. Antwort von Κеүfа 0
    Re: excel felder zusammenrechnen
    Hallo,

    wenn du Zellen zusammenzählen willst benutze einfach den Befehl Summe
    bsp.:
    =SUMME(A1:A50)
    Wenn in der Liste leere Zellen sind, werden diese wie eine Null behandelt und haben somit keinen Einfluss auf das Ergebniss.
    • Antwort von Τһоmаѕ Rеіm 0
      Re: excel felder zusammenrechnen
      Ich würde es nicht so kompliziert machen, versuch doch einfach die AutoSumme, die leeren Felder ersetzt du duch null (Suchen und auswählen dann ersetzen)
      Gruß Thomas
      • Antwort von Κаrіn Dеһnе 0
        Re: excel felder zusammenrechnen
        Hallo,
        mein Tipp: benutze zum Erstellen Deiner Formel den Formelassistenten. Das Ergebnis müsste dann ungefähr so aussehen =Wenn(A3>0;A1:A3;""). Beende Deine Formel mit der Tastenkombination Strg+Umschalt+Eingabe statt nur die Eingabetaste zu drücken. Dann sollte es keine Fehlermeldung mehr geben. Viel Glück!

        Karin
        • Antwort von Αlеx 0
          Re: excel felder zusammenrechnen
          Hallo papabaer,

          ich meine, dass Wenn-Abfragen eh nur begrenzt verschachtelbar sind. Da würdest Du also nicht weit kommen.

          Grundsätzlich verstehe ich Dein Problem nicht ganz, weil eine Zelle mit dem Wert Null ja eh keinen Einfluss auf die Addition hätte. Oder hast Du negative Werte da drinnen, die nicht mit addiert werden sollen?

          Wie wäre es, wenn Du Dir Hilfsspalten baust. Dort prüfst Du dann den Wert in der ersten Spalte mit einer einfachen Wenn-Abfrage und gibst den zu addierenden Wert in der Hilfsspalte aus. Genauso gehst Du auch mit allen anderen Spalten vor und addierst dann einfach die so herausgefundenen Werte.

          Falls ich Dein Problem falsch verstehe, lade doch bitte mal Deine Tabelle hoch.

          Viele Grüße
          Alex
          • Antwort von Μаnuеlа 0
            Re: excel felder zusammenrechnen
            Versuchs mal mit =wenn(a1>0;a1;wenn(a2>0;SUMME(A1:A2);wenn(a3>0;Summe(a1:a3);"")

            Ansonsten schick mir mal ein Bsp, daß ich eine bessere Vorstellung habe.
            Mollym@web.de
            • Antwort von Μаgіс Wоmаn 0
              Re: excel felder zusammenrechnen

              hallo an alle
              ich möchte in excel eine liste zusammenrechnen aber nur wenn
              in diesen feldern ein eintreg gemacht wurde. die listen sind
              unterschiedlich lang.
              wie mache ich es, dass nur felder berücksichtigt werden in denen ein eintrag gemacht wurde und die leeren nicht
              berücksichtigt werden.
              habe es mit =wenn(a1>0;a1;wenn(a2>0;a1+a2;wenn(a3>0;a1:a3;"")
              versucht, bekomme aber als ergebniss immer
              #wert!bitte helft mir
              Hallo pappabaer,
              leider komme ich mit der Frage nicht klar.

              Normalerweise berechnet Excel eine Summe mit der Formel =SUMME(A1:An), wobei "n" für die Zeilennummer der Zelle in der Spalte A steht. Dabei ist es unerheblich, ob in den einzelnen Zellen Einträge gemacht wurden oder nicht. Kein Eintrag bedeutet 0.

              Ist es das, was Du wissen möchtest?
              Grüße
              MW