Tabellenkalkulation
Von: mоrbuѕ78 (abgemeldet), 1.3.2010 14:40 Uhr
Hallo,

Ich habe eine Zeitreihe inkl. Werten über 20 Jahre und möchte nun für jeden Tag einen Mittelwert bilden.

z.B. Mittelwert aus den Werten vom 1.1.1990, 1.1.1991,....,1.1.2010

Mit der Summewenn Funktion geht das nur bedingt, da ich für jeden Tag im Jahr das Suchkriterium eintragen müsste [=SUMMEWENN(B:C;"01.01.*";C:C)]
Kann man das Suchkriterium so definieren, dass es auf den Tag und das Monat in der Datumsspalte Bezug nimmt?



  1. Antwort von Τһоmаѕ Rаmеl 1
    Re: Excel: Summe für ein bestimmtes Datum
    Grüezi Morbus Ich habe eine Zeitreihe inkl. Werten über 20 Jahre und möchte
    nun für jeden Tag einen Mittelwert bilden.

    z.B. Mittelwert aus den Werten vom 1.1.1990,
    1.1.1991,....,1.1.2010

    Kann man das Suchkriterium so definieren, dass es auf den Tag
    und das Monat in der Datumsspalte Bezug nimmt?
    Vergib deinen beiden Spalten eine Überschrift (Datum und Wert)

    Erstelle dann eine Pivot-Tabelle mit den Daten und ziehe das Feld 'Datum' in den Zeilenbereich und das Fels 'Wert' in den Datenbereich des Pivot-Rasters.
    Mit einem Rechtsklick und 'Feldeinstellungen' im Wertebereich kannst Du dann anstelle von 'summe' 'Mittelwert' wählen.

    Und die Datumsspalte gruppierst Du mit Rechtsklick/Gruppieren nach Monat und Tag.


    Damit hast Du dann die gesamte Auswertung abgeschlossen.


    Mit freundlichen Grüssen

    Thomas Ramel
    - MVP für MS-Excel -
    4 Kommentare
    • Re^2: Excel: Summe für ein bestimmtes Datum
      Und die Datumsspalte gruppierst Du mit Rechtsklick/Gruppieren
      nach Monat und Tag.
      Grüzi Thomas

      Ich habe nach Deinen Angaben eine Pivot-Tabelle erstellt und wollte sie nach Monat und Tag gruppieren. Dabei erhalte ich die Fehlermeldung: "Kann den markierten Bereich nicht gruppieren."

      In der Hilfe fand ich folgenden Hinweis: "Das Gruppieren numerischer Elemente, Datums- und Zeitangabe steht für einige Arten von Quelldaten nicht zur Verfügung."

      Hast Du eine Ahnung, warum das bei mir nicht geht, dieses Gruppieren? Muss ich das Datum allenfalls anders erfassen? Ich habe es jetzt als TT.MM.JJJJ formatiert erfasst.

      Ich arbeite mit Excel 2003.

      Vielen Dank für Deine Bemühungen und einen schönen Abend.
      Niclaus
    • Re^3: Excel: Summe für ein bestimmtes Datum
      Ich habe nach Deinen Angaben eine Pivot-Tabelle erstellt und
      wollte sie nach Monat und Tag gruppieren. Dabei erhalte ich
      die Fehlermeldung: "Kann den markierten Bereich nicht
      gruppieren."
      Hallo Niclaus,

      was ist da zu tun?

      http://lmgtfy.com/?q=%22Kann+den+markierten+Bereich+...

      Ich find das witzig *gg*

      Due ersten Treffer sind von einem Lieblingsforum von Thomas :-)

      Gruß
      Reinhard
    • Re^3: Excel: Summe für ein bestimmtes Datum
      Grüezi Niclaus Und die Datumsspalte gruppierst Du mit Rechtsklick/Gruppieren
      nach Monat und Tag.
      Ich habe nach Deinen Angaben eine Pivot-Tabelle erstellt und
      wollte sie nach Monat und Tag gruppieren. Dabei erhalte ich
      die Fehlermeldung: "Kann den markierten Bereich nicht
      gruppieren."

      In der Hilfe fand ich folgenden Hinweis: "Das Gruppieren
      numerischer Elemente, Datums- und Zeitangabe steht für einige
      Arten von Quelldaten nicht zur Verfügung."

      Hast Du eine Ahnung, warum das bei mir nicht geht, dieses
      Gruppieren? Muss ich das Datum allenfalls anders erfassen? Ich
      habe es jetzt als TT.MM.JJJJ formatiert erfasst.

      Ich arbeite mit Excel 2003.
      Entweder hast Du die kompletten Spalten als Datenquelle markiert, oder Du hast leere Zellen in der Datumsspalte oder mindestens einer deiner Datusmwerte liegt im Textformat vor.

      In allen diesen Fällen lässt sich das Datum (logischerweise) nicht gruppieren.

      Mit freundlichen Grüssen

      Thomas Ramel
      - MVP für MS-Excel -
    • Re^4: Excel: Summe für ein bestimmtes Datum
      Entweder hast Du die kompletten Spalten als Datenquelle
      markiert, oder Du hast leere Zellen in der Datumsspalte oder
      mindestens einer deiner Datusmwerte liegt im Textformat vor.
      Grüezi Thomas
      Vielen Dank für Deine Hinweise. Es hat nun geklappt.
      Ich habe folgendes gemacht: In einer Hilfsspalte habe ich das Datum übernommen mit =DATUM(JAHR(A2);MONAT(A2)... usw. Diese Hilfsspalte habe ich kopiert und in eine weitere Spalte als Werte eingefügt. Mit dieser Spalte ging's ohne Probleme.
      Ich habe die Originalspalte und diese "weitere" Spalte verglichen: = A2=C2. Das Ergebnis war überall WAHR. Ich habe die Originalspalte auch gecheckt mit =ISTZAHL(A2) usw. Auch da ist alles WAHR.
      Es scheint also, dass in der Originalspalte kein Datum als Text erfasst wurde.
      Hauptsache es klappt - und ich habe wieder mal was gelernt dank Deiner Hilfe.
      Viele Grüsse
      Niclaus
  2. Antwort von Rеіnһаrd 0
    Re: Excel: Summe für ein bestimmtes Datum
    Mit der Summewenn Funktion geht das nur bedingt, da ich für
    jeden Tag im Jahr das Suchkriterium eintragen müsste
    [=SUMMEWENN(B:C;"01.01.*";C:C)]
    Kann man das Suchkriterium so definieren, dass es auf den Tag
    und das Monat in der Datumsspalte Bezug nimmt?
    Hallo Morbus,

    zeigemal eine Beispielmappe, FAQ:2606

    Gruß
    Reinhard
    3 Kommentare
    • Re^3: Excel: Summe für ein bestimmtes Datum
      Hallo Morbus!

      Wenn du Platz für eine Hilfsspalte hast, gehts mit Summewenn()

      Formel für die Hilfsspalte =TAG(A1)&MONAT(A1)
      Summewenn geht dann so =SUMMEWENN(C:C;TAG(A1)&MONAT(A1);B:B). Die kannst du runterziehen bis Zeile 366 und hast dann für jeden Tag die Summe. Wenn du nur bestimmte Tage ausgeben möchtest, kannst du die Formel =SUMMEWENN(C:C;E1;B:B) nehmen. In E1 steht das Datum im Format TM - also der Datumswert aus der Hilfsspalte. Wenn du Fragen dazu hast, bitte melde dich nochmal.

      Gruß alex
    • von Αnја 0
      Re^4: Excel: Summe für ein bestimmtes Datum
      Hallo,

      kleine Korrektur Formel für die Hilfsspalte =TAG(A1)&MONAT(A1)
      Besser noch einen Trenner einfügen, also z.B. so:

      =TAG(A1)&"-"&MONAT(A1)

      Schließlich sollen z.B. der 1.12. und der 11.2. separat behandelt werden.

      Gruß
      A
  3. Antwort von Rеіnһаrd 0
    Re: Excel: Summe für ein bestimmtes Datum
    Ich habe eine Zeitreihe inkl. Werten über 20 Jahre und möchte
    nun für jeden Tag einen Mittelwert bilden.

    z.B. Mittelwert aus den Werten vom 1.1.1990,
    1.1.1991,....,1.1.2010

    Mit der Summewenn Funktion geht das nur bedingt, da ich für
    jeden Tag im Jahr das Suchkriterium eintragen müsste
    [=SUMMEWENN(B:C;"01.01.*";C:C)]
    Kann man das Suchkriterium so definieren, dass es auf den Tag
    und das Monat in der Datumsspalte Bezug nimmt?
    Hallo Morbus,

    schreib mal in F1:
    =WENN(SUMMENPRODUKT((TAG(A2:$A$2000)=TAG(A1))*(MONAT(A2:$A$2000)=MONAT(A1)))=0;SUMMENPRODUKT((TAG($A$1:$A$2000)=TAG(A1))*(MONAT($A$1:$A$2000)=MONAT(A1))*$C$1:$C$2000);"")

    Und kopiere es bis unten bzw. bis F1717

    Gruß
    Reinhard