Tabellenkalkulation
Von: DC-Warez (abgemeldet), 23.7.2011 20:56 Uhr
Hallo

ich mache gerade eine Excel Tabelle die den Brutto Lohn und die Spesen ausrechnen soll. An und für sich für mich überhaupt kein Thema aber i-wie stell ich mich glaub zu dumm an bei der Spesen Formel

=WENN((SUMME(B2:D2))>7,99;6;WENN(SUMME(B2:D2))>13,99;12;0)

Ab 8Std gibts 6 ab 14 Std gibts 12 und bei weniger als 8 gibts Nix. Die Stunden zahl gibts auch noch in drei werten (lohnB2 FahrzeitC2 sonstigezeitD3) deswegen drei spalten.



  1. Antwort von Armin Lommel 0
    Re: Excel Wenn Formel fehlerhaft #WERT oder #NAME
    Hallo DC-Warez,

    die Wenn Bedingung istnur für zwei Möglichkeiten gedacht, die müßtest Du also schachteln oder den Fall mit weniger als 8 ausschliesen.
    =WENN((SUMME(B2:D2))>13,99;12;6)
    Wenn Bedingung erfüllt gibts 12 sonst nur 6, die Prüfung auf weniger muss dann nochmal mit WENN gemacht werden. Am besten erst mal in zwei Zellen probieren.

    Soweit klar?

    Gruß Armin
    1 Kommentare
    • von DC-Warez (abgemeldet) 0
      Re^2: Excel Wenn Formel fehlerhaft #WERT oder #NAME
      Hallo Armin,

      Das mit zwei zellen bzw spalten zu machen ist ja generell kein problem ich war nur der Meinung das man die Wenn funktion endlos strecken konnte mit Office 2007 und somit jede weitere spalte überflüssig macht der Übersichtlichkeit halber.

      Aber ich habs bereits so gemacht und füge unten an der Abrechnung eine weitere Spalte mit Summe ein und dann passts ja auch.

      Danke für die Rasche Antwort!!!


      LG

      Dominik
  2. Re: Excel Wenn Formel fehlerhaft #WERT oder #NAME
    Hallo ich helfe gerne. Versteh aber Dein Problem noch nicht ganz. Du hast eine Klammer zuviel: Deine Formel muss so aussehen.=WENN(SUMME(B2:D2)>7,99;6;WENN(SUMME(B2:D2)>13,99;12;0))
    • Antwort von Chris41 0
      Re: Excel Wenn Formel fehlerhaft #WERT oder #NAME
      WENN(SUMME(B2:D2)>=8;WENN(SUMME(B2:D2)>=14;12;6);0)



      =WENN((SUMME(B2:D2))>7,99;6;WENN(SUMME(B2:D2))>13,99;12;0)

      Ab 8Std gibts 6 ab 14 Std gibts 12 und bei weniger als 8 gibts
      Nix. Die Stunden zahl gibts auch noch in drei werten (lohnB2
      FahrzeitC2 sonstigezeitD3) deswegen drei spalten.
      • Antwort von Kurt Fortwängler 0
        Re: Excel Wenn Formel fehlerhaft #WERT oder #NAME
        Hallo DC-Warez,

        die Frage ist nicht ganz klar formuliert. Willst Du wissen, was an der Formel falsch ist (der Grund für #Wert/#Name)?

        Definitiv gibt es da einen Fehler mit den Klammern! Zähl die doch mal ab...
        =WENN((SUMME(B2:D2))>7,99;6;WENN(SUMME(B2:D2))>13,99;12;0)

        Im zweiten WENN hast Du vor SUMME keine öffnende Klammer (wie im ersten WENN). Deshalb ist hier die zweite schließende Klammer falsch! Denn dadurch besteht das zweite WENN nur aus der Bedingung!
        =WENN(SUMME(B2:D2)>7,99;6;WENN(SUMME(B2:D2)>13,99;12;0))


        Ob der Rest stimmt (z.B. das Komma als Dezimaltrennzeichen bzw. die Zellbezüge), ist von hier aus nicht zu klären. Im Zweifelsfall würde ich die Formel in ihren Einzelteilen in Zellen hineinschreiben, um dem Fehler auf die Spur zu kommen.

        Liebe Grüße,
        Kurt
        • Antwort von Reinhard 0
          Re: Excel Wenn Formel fehlerhaft #WERT oder #NAME
          Hallo,
          also erstens würde ich die Bedingung (WENN-Abfrage) NICHT mit >7,99 sondern, wie Du es wünscht, ab 8 Std.; d.h. doch bei 8 Std. oder mehr?? --> also >=8 bzw. anstatt >13,99 --> >=14 definieren!
          Zweitens folgt IMMER die erste WENN-Abfrage NACH der zweiten usw., d.h. Du musst zuerst die Abfrage nach dem größten Wert, dann nach dem zweitgrößten Wert usw. stellen, sonst ist die erste Abfrage >=8 auch dann "richtig", wenn der Wert >=14 ist, d.h. die bei Dir zweite Abfrage >13,99 findet NIE statt!

          Lösung:
          =WENN((SUMME(B2:D2))>=14;12;WENN(SUMME(B2:D2)>=8;6;0))
          Gruß, Reinhard.
          2 Kommentare
          • von DC-Warez (abgemeldet) 0
            Re^2: Excel Wenn Formel fehlerhaft #WERT oder #NAME
            Ihr habt alle so recht.....DANKE!!!!

            Die Klammer wars und ich war am verzweifeln an mir selbst dabei ist es so simpel; beides geht natürlich >7,99 oder >=8

            Wirklich ann alle meinen besten dank!!
          • von Reinhard 0
            Re^3: Excel Wenn Formel fehlerhaft #WERT oder #NAME
            Guten Morgen,
            nur eine kleine Anmerkung zu Deiner Aussage:
            "beides geht natürlich >7,99 oder >=8"
            Natürlich GEHT beides!
            ABER beides führt zu anderen Ergebnissen, wenn der WERT=7,991...7,999999:
            (WENN "Wert" >7,99 --> Ergebnis: 6;
            WENN "Wert" >=8 --> Ergebnis: 0!
            Das mag kleinlich klingen, ist aber in Deinem Fall von großer Bedeutung, da ja bei exakt >=8 (und eben nicht bei >7,99) sich wesentliches ändern soll!
            Gruß Reinhard.
        • Antwort von schlereth1974 0
          Re: Excel Wenn Formel fehlerhaft #WERT oder #NAME
          Hallo,

          das zweite Wenn muss in Klammern, dann sollte es klappen:
          =WENN((SUMME(B2:D2))>7,99;6;(WENN(SUMME(B2:D2))>13,99;12;0))
          • Antwort von Noedi 0
            Re: Excel Wenn Formel fehlerhaft #WERT oder #NAME
            Hi DC Warez,

            die Bedingungen stehen falsch rum.
            B2:D2 > 7,99 ist auch erfüllt wenn B2:D2 > 13,99, also bekommst Du als Ergebnis auch 6 wenn die Stundenzahl über 13,99 liegt. Stellst Du die Bedingungen anders rum funktioniert es.
            Die Fehlermeldung #Wert oder #Name kann ich mir nicht erklären ohne, dass ich die Datei in Händen halte.

            Falls Du interesse hast sende die Datei an info@meinefussmatten.de

            P.S.: Hast Du B2:D2 auch formatiert als Zahl?

            mfg

            Noedi
            • Antwort von Peter Lendecke 0
              Re: Excel Wenn Formel fehlerhaft #WERT oder #NAME
              Hi,
              Die Formel hat 2 Fehler
              1. Die Klammer war falsch
              2. Die Prioritäten waren falsch gesetzt. Da Excel die "Wenn- Abfrage" von links nach rechts in der Formel macht, muss die Abfrage immer so in der Reihenfolge sein, dass nicht die erste Abfrage bereits die nächste erfüllt. Also in der vorgelegt Formel erfüllt die Abfrage >7,99 bereits alle größeren Zahlen und die Bedingung >13,99 wird garnicht erst erreicht.

              Hier die geänderte Formel:

              =WENN((SUMME(B2:D2))>13,99;12;WENN(SUMME(B2:D2)>7,99;6;0))

              mfg
              PL
              • Antwort von Verena 0
                Re: Excel Wenn Formel fehlerhaft #WERT oder #NAME
                Spesen Formel

                =WENN((SUMME(B2:D2))>7,99;6;WENN(SUMME(B2:D2))>13,99;12;0)

                Ab 8Std gibts 6 ab 14 Std gibts 12 und bei weniger als 8 gibts
                Nix. Die Stunden zahl gibts auch noch in drei werten (lohnB2
                FahrzeitC2 sonstigezeitD3) deswegen drei spalten.
                Hallo,
                zunächst mal fällt mir auf, dass Du die Klammern anscheinend irgendwie "verwurschtelt" hast. Außerdem sollte man bei solchen Abfragen immer "oben" anfangen. Mein Vorschlag wäre:
                =WENN(SUMME(B2:D2)>13,99;12;WENN(SUMME(B2:D2)>7,99;6;0))
                Probier's mal aus und sag mir, ob es geklappt hat, ja?
                Danke und viele Grüße,
                Verena
                • Antwort von Hartmut Göthel (abgemeldet) 0
                  Re: Excel Wenn Formel fehlerhaft #WERT oder #NAME
                  =WENN((SUMME(B2:D2))>7,99;6;WENN(SUMME(B2:D2))>13,99;12;0)

                  Ab 8Std gibts 6 ab 14 Std gibts 12 und bei weniger als 8 gibts
                  Nix. Die Stunden zahl gibts auch noch in drei werten (lohnB2
                  FahrzeitC2 sonstigezeitD3) deswegen drei spalten.
                  Hallo DC-Warez,

                  hier mein Vorschlag für eine entsprechende Formel. Ich habe sie in WORKS getestet, sie müsste aber auch in Excel funktionieren.

                  =WENN(SUMME(B2:D2)<8;0;WENN(SUMME(B2:D2)<14;6;12))

                  Mit Gruß

                  Hartmut
                  • Antwort von Karola Arning (abgemeldet) 0
                    Re: Excel Wenn Formel fehlerhaft #WERT oder #NAME
                    Hallo.
                    die Formel muss vom großen zum kleinen Wert aufgebaut sein, denn die Zahl 15 ist sowohl größer als 8 als auch 14 - hier die richtige Formel:
                    =WENN(SUMME(B2:D2)>13,99;12;WENN(SUMME(B2:D2)>7,99;6;0))
                    viel Spaß!
                    • Antwort von Uschi : D 0
                      Re: Excel Wenn Formel fehlerhaft #WERT oder #NAME
                      LogikfehlerDein Wert kommt dehalb in Schwierigkeiten, dass er bei 14 sowohl größer als 7,99 als auch größer 13,99, dann weiß er nicht, welchen Wert er einsetzen soll. du müsstest eine Formel haben, die zwischen 8 und 14 abprüft, aber
                      wenn(.....)>7,99^<14 Tut mir leid- war verreist, deshalb die späte Antwort
                      uschi
                      • Antwort von Jens_1701 0
                        Re: Excel Wenn Formel fehlerhaft #WERT oder #NAME
                        Hallo,

                        sorry, ich befinde mich gerade im Urlaub und kann die Frage leider nicht beantworten.

                        Jens