Tabellenkalkulation
Von: Rаúl Rіνаldо, 30.12.2004 11:50 Uhr
Hallo Excel-Experten,

ich möchte in einer Formel eine Teilsumme mit einer Zählenwenn-Funktion verschachteln.

Beispiel:
Ich filtere aus einer Tabelle Datensätze, die einem bestimmten Kriterium entsprechen (Funktion: =TEILERGEBNIS(9;K3:K73) ). Nun möchte ich die Anzahl der gefilterten Zellen (in Spalte K) zählen, die größer 0 sind.

Wie verschachtelt man die beiden Funktionen?

Danke im voraus,
Raulito



  1. Antwort von Αngеl 1
    Re: Teilsumme und Zählenwenn verschachteln
    Hallo Raulito,
    es ist vielleicht nicht ganz genau, was du suchst - also alle gefilterten Zellen, die größer sind als 0 - aber mit der Formel: =TEILERGEBNIS(3;K3:K73) wird zumindest die Summe aller gefilterten Zellen gezählt.

    Liebe Grüße und einen guten Rutsch wünscht
    Angel
    1 Kommentare
    • das paßt :-)
      Hallo Angel, es ist vielleicht nicht ganz genau, was du suchst aber mit der
      Formel: =TEILERGEBNIS(3;K3:K73) wird zumindest die Summe aller
      gefilterten Zellen gezählt.
      Doch...das ist genau das, was ich suche. Einfach nur die Funktion 9 gegen die 3 austauschen...daß ich da nicht selbst drauf gekommen bin...

      Vielen Dank für Deine Hilfe. Wünsche Dir auch einen guten Rutsch,
      Raulito :-)
  2. Antwort von mісһаеl 0
    Re: Teilsumme und Zählenwenn verschachteln
    hi,
    ich möchte in einer Formel eine Teilsumme mit einer
    Zählenwenn-Funktion verschachteln.
    warum unbedingt verschachteln? Ich filtere aus einer Tabelle Datensätze, die einem bestimmten
    Kriterium entsprechen (Funktion: =TEILERGEBNIS(9;K3:K73) ).
    Nun möchte ich die Anzahl der gefilterten Zellen (in Spalte K)
    zählen, die größer 0 sind.
    möchtest du über die summieren, die größer als 0 sind? das wäre dann:
    =SUMMEWENN(K3:K73;">0";K3:K73)
    möchtest du die zählen, die größer als 0 sind? das wäre dann:
    =ZÄHLENWENN(K3:K73;">0")

    wenns beides nicht ist, hab ich das problem noch nicht verstanden.
    hth
    m.

    p.s.:
    ich finds im übrigen die SUMME aller dummheit, WENN ein softwarehersteller verhindert, dass in seinem deutschsprachigen produkt die internationalen (bzw. englischen) funktionen wie SUMIF, COUNTIF, SUBTOTAL nicht funktionieren. wenn ich "SUMMEWENN" nur schon hör ... *grin*
    3 Kommentare
    • geht so nicht
      Hallo Michael, warum unbedingt verschachteln?
      Weil's der sicherste Weg ist. Das ganze funktioniert auch mit einer Hilfsspalte und einer Zwischenberechnung dort. Wenn jedoch die Tabelle erweitert wird, muß man jedesmal daran denken, auch die Hilfsspalte zu erweitern. Das möchte ich vermeiden. möchtest du über die summieren, die größer als 0 sind? das
      wäre dann:
      =SUMMEWENN(K3:K73;">0";K3:K73)
      möchtest du die zählen, die größer als 0 sind? das wäre dann:
      =ZÄHLENWENN(K3:K73;">0")

      wenns beides nicht ist, hab ich das problem noch nicht
      verstanden.
      Ist beides nicht. Ich möchte aus einem gefilterten Bereich heraus die Anzahl der Zellen in einer Spalte zählen lassen, die größer 0 sind. Wenn ich nur mit Zählenwenn arbeite (=ZÄHLENWENN(K3:K73;">0"), bekomme ich das Ergebnis für die gesamte Tabelle, ich brauche aber das Ergebnis nur aus dem gefilterten Bereich, also nicht auch von den bei der Filterung ausgeblendeten Zeilen.
      Ich hoffe,ich habe das jetzt ein bißchen verständlicher ausgedrückt.

      Danke nochmal,
      Raúl
    • Re: geht so nicht
      hi, möchtest du über die summieren, die größer als 0 sind? das
      wäre dann:
      =SUMMEWENN(K3:K73;">0";K3:K73)
      möchtest du die zählen, die größer als 0 sind? das wäre dann:
      =ZÄHLENWENN(K3:K73;">0")

      wenns beides nicht ist, hab ich das problem noch nicht
      verstanden.
      Ist beides nicht. Ich möchte aus einem gefilterten Bereich
      heraus die Anzahl der Zellen in einer Spalte zählen lassen,
      die größer 0 sind. Wenn ich nur mit Zählenwenn arbeite
      (=ZÄHLENWENN(K3:K73;">0"), bekomme ich das Ergebnis
      für die gesamte Tabelle, ich brauche aber das Ergebnis nur aus
      dem gefilterten Bereich, also nicht auch von den bei der
      Filterung ausgeblendeten Zeilen.
      Ich hoffe,ich habe das jetzt ein bißchen verständlicher
      ausgedrückt.
      versteh ichs richtig: ">0" ist nur ein kriterium; in wirklichkeit möchtest du den bereich K3:K73 noch nach anderen kriterien filtern und das gefilterte ergebnis nach werten >0 durchzählen?
      stimmt das?
      wenn ja: welche filterkriterien sind denn das?

      ???
      m.
    • Re^2: geht so nicht
      versteh ichs richtig: ">0" ist nur ein kriterium; in
      wirklichkeit möchtest du den bereich K3:K73 noch nach anderen
      kriterien filtern und das gefilterte ergebnis nach werten
      >0 durchzählen?
      stimmt das?
      Genauso. wenn ja: welche filterkriterien sind denn das?
      Ich filtere alle Werte heraus, die z.B. zu England (Spalte C) gehören und nur wenn in Spalte K ein Wert größer 0 steht, soll (die Anzahl der Zellen in Spalte K mit Werten größer 0) gezählt werden.
      Mit nur "ZÄHLENWENN" als Funktion bekomme ich wie gesagt nicht nur die gefilterten Werte zu England sondern alle anderen auch.
  3. Antwort von Rеіnһаrd 1
    Re: Teilsumme und Zählenwenn verschachteln
    ich möchte in einer Formel eine Teilsumme mit einer
    Zählenwenn-Funktion verschachteln.
    Beispiel:
    Ich filtere aus einer Tabelle Datensätze, die einem bestimmten
    Kriterium entsprechen (Funktion: =TEILERGEBNIS(9;K3:K73) ).
    Nun möchte ich die Anzahl der gefilterten Zellen (in Spalte K)
    zählen, die größer 0 sind.
    Wie verschachtelt man die beiden Funktionen?
    Hola Raulito,
    in B1 machste einen Autofilter, so dass nur Zeilen angezeigt werden die in B2:B73 "England" stehen haben.
    Die Anzahl der Zellen in dieser gefilterten Liste die in K einen Wert größer Null haben erhälst du dann mit:

    =SUMMENPRODUKT(TEILERGEBNIS(3;INDIREKT("K"&ZEILE(3:73)))*(K3:K73>0))

    Gruß
    Reinhard
    2 Kommentare
    • viele Wege führen nach Rom
      Hola Reinhard,

      hast Du diese Formel bei excelformeln.de gesehen? Da gibt es so eine Formel für den Zellwert ="X" (statt >0) und ich habe sie leider nicht für meinen Zweck "umformeln" können. Deine Formel ist im Vergleich zur "schlichten" Lösung von Angel very sophisticated. Wenn Du das selbst gebastelt hast...chapeau

      Vielen Dank für Deine Unterstützung und guten Rutsch,
      Raulito
    • Re: viele Wege führen nach Rom
      hast Du diese Formel bei excelformeln.de gesehen? Da gibt es
      so eine Formel für den Zellwert ="X" (statt >0) und ich
      habe sie leider nicht für meinen Zweck "umformeln" können.
      Deine Formel ist im Vergleich zur "schlichten" Lösung von
      Angel very sophisticated. Wenn Du das selbst gebastelt
      hast...chapeau
      Hola Raulito,
      die Jungs bei excelformeln leben in einer anderen Welt *g
      Eine Menge Formeln werde ich nie kapieren. Bin schon sehr froh wenn ich Formeln von dort "umformeln" kann dass sie für andere Spalten u.ä. funktionieren.
      Gruß
      Reinhard