Tabellenkalkulation
Von: nirwarna, 18.3.2009 13:52 Uhr
Hallo
Ich habe in der Zelle A1 einen wert stehen.
Diesen möchte ich mit einer Spalte vergleichen, ob er da vorkommt.

Wenn ja, soll aber nicht das Ergebnis des gefunden Wertes, sondern der Wert der nächsten Spalte beim gleichen Index eingetragen werden.

Beispiel:

A1 = Eins

Spalte spalte nebendran
Zehn Äpfel
Sieben Birnen
Acht Kirsche
Eins Pflaumen

Ergebnis wäre Pflaumen in der Zelle mit der Abfrage

Ich hab schon mit
=SVERWEIS(A1;Postleitzahlen!A$2:A$8197;1;FALSCH)

die Lösung, das er den gefundenen Wert einträgt.
Aber ich will ja den beim gleichen Index (Zeile) in der Spalte nebenan.

Bitte schnell helfen!!

mfg Werner



  1. Antwort von Reinhard 0
    Re: Zellwert mit Spalte vergleichen
    Ich habe in der Zelle A1 einen wert stehen.
    Diesen möchte ich mit einer Spalte vergleichen, ob er da
    vorkommt.

    Wenn ja, soll aber nicht das Ergebnis des gefunden Wertes,
    sondern der Wert der nächsten Spalte beim gleichen Index
    eingetragen werden.
    Hallo Werner,

    =SVERWEIS(A1;Postleitzahlen!A$2:B$8197;2;FALSCH)

    Gruß
    Reinhard
    3 Kommentare
    • von nirwarna 0
      Re^2: Zellwert mit Spalte vergleichen
      Hi
      das geht nicht, steht dann Name# drin.
      Frage bleibt.

      Alternativ:
      Sag mir , wenn in einer Zelle "Postleitzahlen!" &"B" & H5 drin steht
      wie kann ich den Inhalt der Zelle als Zelle verknüpfen.

      ZB ich schreib in die Zelle A1 als Text.
      Und möchte den Text als Zelle verlinken.

      Quasi anstatt der Zuweisung = Zellinhalt A1 will ich den Text als aktuelle Zellzuweisung, das geht auch net, kommt immer Fehler.

      mfg Werner
    • von nirwarna 0
      Re^3: Zellwert mit Spalte vergleichen
      Ah ich muss die Spalte B mit einbeziehen in die Suche, dann ist die Zahl die Ausgabe also 2 =Wert in Spalte B, richtig?

      Vielleicht kannst du die Frage mit dem Text aus der Zelle trotzdem beantworten.

      Mfg Werner
    • von Reinhard 0
      Re^3: Zellwert mit Spalte vergleichen
      Hallo Werner,

      =SVERWEIS(A1;Postleitzahlen!A$2:B$8197;2;FALSCH) das geht nicht, steht dann Name# drin.
      Frage bleibt.
      dann hast du etwas falsch geschrieben. Alternativ:
      Sag mir , wenn in einer Zelle "Postleitzahlen!" &"B" & H5 drin
      steht
      wie kann ich den Inhalt der Zelle als Zelle verknüpfen.
      Tabellenblatt: [Mappe2]!Tabelle1
        │         A         │ B │ C │
      ──┼───────────────────┼───┼───┤
      1 │ Postleitzahlen!B3 │   │ 3 │
      ──┼───────────────────┼───┼───┤
      2 │ t                 │   │   │
      ──┴───────────────────┴───┴───┘
      Benutzte Formeln:
      A1: ="Postleitzahlen!"&"B"&C1
      A2: =INDIREKT(A1)
      

      Tabellendarstellung erreicht mit dem Code in FAQ:2363

      Gruß
      Reinhard