Tabellenkalkulation
Von: Marsson, 26.4.2007 14:00 Uhr
Hallo allerseits,

ich habe eine Frage zu einem "Excelproblem".
Meine Tabelle hat drei Spalten (A-C und z.B. 1 - 10).
In Spalte C stehen Zahlen.
In den ersten beiden Spalten kann jeweils entweder ein "X" oder "Y" stehen. Also in beiden "Y", ein "X" und ein "Y" bzw zwei "X".

Ich möchte nun die Zahlen aus der dritten Spalte summieren, allerdings nur die, bei denen in beiden vorgestellten Spalten ein "X" steht. Habe bisher leider keine Lösung gefunden. Hoffe, jemand kann mir weiterhelfen.

Viele Grüße Martin



  1. Antwort von Alex Winter 1
    Re: Zwei Bedingungen abfragen?
    Hallo Martin,
    Ich möchte nun die Zahlen aus der dritten Spalte summieren,
    allerdings nur die, bei denen in beiden vorgestellten Spalten
    ein "X" steht. Habe bisher leider keine Lösung gefunden.
    Hoffe, jemand kann mir weiterhelfen.
    Das geht mit einer Matrixformel, die ich auf http://www.excelformeln.de/formeln.html?welcher=61 gefunden habe. Die geschweiften Klammern erreichst du wie üblich über die Kombi STRG+SHIFT+ENTER
    {=SUMME((A1:A100="x")*(B1:B100="y")*C1:C100)} Viele Grüße Alex
    1 Kommentare
    • von Marsson 0
      Das wars...
      Hi Alex,

      danke für den Tipp. Das war die Lösung. Matrixformel kannte ich gar nicht :-(

      Gruß Martin
  2. Antwort von Hooky 0
    Re: Zwei Bedingungen abfragen?
    Hallo Martin,

    ich verstehe deine Problemstellung nich so richtig, aber evtl. hilft
    die ja auch so
    =WENN(B1="X";C1;0)
    weiter.
    Wenn in B1 "X" steht wird der Wert aus C1 genommen, wenn nicht "O".

    Gruß
    Hooky
    1 Kommentare
    • von Marsson 0
      Re^2: Zwei Bedingungen abfragen?
      Hi, =WENN(B1="X";C1;0)
      Ich möchte ja die Spalte A UND B abfragen...
      Wenn also z.B. in A5 und B5 und ausserdem noch in A8 und B8 ein "X" steht, sollen die Zahlen in C5 und C8 summiert werden! War das klarer??

      Martin
  3. Antwort von Jörg Z. 0
    Re: Zwei Bedingungen abfragen?
    Hi

    evtl so: =ZÄHLENWENN(A1:A10;"=x")+ZÄHLENWENN(B1:B10;"=x")


    Gruß´Jörg [Bei dieser Antwort wurde das Vollzitat nachträglich automatisiert entfernt]
    1 Kommentare
    • von Marsson 0
      Re^2: Zwei Bedingungen abfragen?
      Hi Jörg, evtl so: =ZÄHLENWENN(A1:A10;"=x")+ZÄHLENWENN(B1:B10;"=x")
      so zähle ich ja nur die Anzahl der "X" in den Spalten A und B. Ich wollte aber die Zahlen in Spalte C entsprechend SUMMIEREN...
      Hoffe auf noch eine Hilfe

      Martin
  4. Antwort von Verena 0
    Re: Excelformeln, Ergänzung
    Auf der von Alex Winter erwähnten Seite habe ich übrigens noch einen Weg gefunden, nämlich den, dass man mittels einer Hilfsspalte z. B. Spalte A und Spalte B verbindet (=A&B heißt das, glaube ich) und dann damit weitermacht. Fand ich persönlich sogar noch leichter ...
    Gruß Verena ich habe eine Frage zu einem "Excelproblem".
    Meine Tabelle hat drei Spalten (A-C und z.B. 1 - 10).
    In Spalte C stehen Zahlen.
    In den ersten beiden Spalten kann jeweils entweder ein "X"
    oder "Y" stehen. Also in beiden "Y", ein "X" und ein "Y" bzw
    zwei "X".
    Ich möchte nun die Zahlen aus der dritten Spalte summieren,
    allerdings nur die, bei denen in beiden vorgestellten Spalten
    ein "X" steht. Habe bisher leider keine Lösung gefunden.
    Hoffe, jemand kann mir weiterhelfen.
    Viele Grüße Martin
    1 Kommentare
    • Re^2: Excelformeln, Ergänzung
      Hallo Verena! Auf der von Alex Winter erwähnten Seite habe ich übrigens noch
      einen Weg gefunden, nämlich den, dass man mittels einer
      Hilfsspalte z. B. Spalte A und Spalte B verbindet (=A&B heißt
      das, glaube ich) und dann damit weitermacht. Fand ich
      persönlich sogar noch leichter ...
      Ja, du hast recht, das könnte man auch so lösen, aber gegen Hilfsspalten hab ich persönlich was.... *gg*. Es geht aber auch ohne. Du kannst die Verbindung auch als Summewenn-Kriterium eingeben. Gruß Alex